Magento 2 e configurações mínimas do ambiente de instalação

Característico por sua abundância em funcionalidades e confortável no que se refere a eficácia em organização de um e-commerce, o Magento 2 exige uma quantidade elevada de recursos do servidor onde está hospedado. Abaixo listamos as competências que deverão estar disponíveis em sua hospedagem para que a instalação do Magento 2 funcione de maneira plena e veloz.

 

Sistema operacional

Distribuições Linux (x86-64), CentOS, Ubuntu, Debian e assim por diante.

Quantidade de memória

Para que a atualização da plataforma Magento possa ser efetuada, incluindo todos os aplicativos e extensões (módulos), do Marketplace, até 2 GB de memória podem ser necessários (esta é a definição que encontramos na documentação oficial).

Na prática (ou melhor: com a mão na massa), antes de definirmos a quantidade de memória suficiente para rodar a nossa instalação Magento 2, é conveniente refletirmos sobre as seguintes questões:

Qual a quantidade de produtos que serão cadastrados em minha loja (em um período de tempo curto e médio)?

O servidor será otimizado ao máximo (seja com a utilização de aceleradores, compactação/compressão de arquivos, diminuição de imagens, etc…)?

A limpeza (redução) do banco de dados será efetuada de maneira periódica e satisfatória?

Qual a quantidade de visitantes que pretendo receber diariamente (incluindo acréscimos, elevações, horários de píco e eventuais campanhas de marketing)?

Após efetuar esta breve reflexão (baseada nos tópicos mencionados acima), e com o intuito de fazer com que novos paradigmas resplandeçam, somos automaticamente conduzidos a concluir que:

A quantidade de memória necessária para rodar o Magento 2 encontra-se diretamente relacionada a demanda individual de cada loja (compreendendo de maneira íntima os diversos recursos fornecidos pela empresa de alojamento).

Hospedagem Magento

A plataforma não deve ser instalada em um ambiente de hospedagem compartilhada, isto é, para que o Magento 2 seja instalado de maneira correta e funcional (em ambiente de produção), recomenda-se a utilização de servidores do tipo VPS, cloud ou dedicado.

Composer

O Composer é essencial para desenvolvedores que desejam colaborar com a base de código do Magento 2 ou qualquer pessoa que deseje desenvolver módulos para Magento. Recomenda-se a utilização da última versão consistente.

Servidor Web

Apache 2.2 ou 2.4;
Nginx 1.8.

Exigências do banco de dados

MySQL 5.6;
MariaDB;
Percona.

Versões do PHP

5.5.x (x >= 22);
5.6.x;
7.0.2 até 7.1.0 (7.0.5 indisponível).

Extensões do PHP necessárias

As orientações de instalação do CentOS e do Ubuntu PHP compreendem uma etapa para instalar as seguintes extensões:

bc-math
curl
gd, ImageMagick 6.3.7 (versão mais elevada – ou as duas)
iconv (unicamente PHP 7)
intl
json (exclusivamente PHP 7)
mbstring
mcrypt
mhash
openssl
PDO/MySQL
SimpleXML
soap
xml
xsl
zip

PHP OPcache

Por questões de performance é extremamente aconselhável que seja confimado se o PHP Opcache está habilitado (comumente se encontra ativo em muitas distribuições do PHP), caso seja necessário efetuar a instalação em particular, consulte a documentação no site oficial.

Configurações do PHP

Aconselhamos que as definições do PHP sejam efetuadas de acordo com a singularidade do seu ambiênte de instalação Magento. O desenvolvedor responsável pelo projeto deverá ser qualificado para executar essa tarefa.

SSL (Secure Socket Layer)

Uma loja virtual que prima pela segurança e confidenciabilidade das informações que trafegam durante o precesso de vendas, com certeza irá utlizar um certificado de segurança HTTPS. Garantindo total integridade das informações fornecidas pelos clientes.

Certificados do tipo autoassinados não são suportados em uma instalação do Magento 2.

Navegadores suportados (visualização de loja e painel administrativo)

Internet Explorer 11 ou superior;
Microsoft Edge (mais recente – 1);
Última versão Firefox (mais recente – 1);
Última versão Chrome (mais recente – 1);
Última versão Safari (mais recente – 1);
Safari Mobile para iPad 2, iPad Mini, iPad com Retina Display (iOS 7 ou posterior), para visualização desktop;
Safari Mobile para iPhone 4 ou posterior;
iOS 7 ou posterior (para visualização de celular);
Chrome for mobile (mais recente – 1);
Android 4 ou posterior (para visualização de celular).

Onde (mais recente – 1) significa uma versão principal anterior à versão mais recente.

Sos

CentOS, Debian, Linux x86-64, Mac OS, Ubuntu, Windows.

Servidor de e-mail

MTA (agente de transporte de e-mail);
Servidor SMTP.

Comportáveis e de uso voluntário

Varnish 3.5 ou mais elevado, Memcached (ultima versão consistente), e Redis 3.0.

Mais informações sobre os pré requisitos para instalação do Magento 2 podem ser encontradas em:
http://devdocs.magento.com/guides/v2.1/install-gde/prereq/prereq-overview.html

Você poderá se interessar por:

Deixe uma resposta

O seu endereço de e-mail não será publicado. Campos obrigatórios são marcados com *